PDA

View Full Version : How many people are running Don's mixture in their gas?



Squire
11-29-2017, 02:23 PM
I use the quickcleen, quickcare and quickstor (numbers 1,2 and 3) for every tank, but I have not
been putting the Premium Plus into the gas in the 150:1 ration (8.5 ounces per 10 gallons).

Just curious as I am going to start this.

http://www.bbcboards.net/showthread.php?t=578178

dirtman
11-29-2017, 05:08 PM
Steve. I add Quikleen every time I put gas in the boat. Don't use the Quikcare or Quikstor. As much as your boat sits though, I would use all 3 just to be sure.

Squire
11-29-2017, 05:42 PM
I do Larry. I was more asking about adding 8.5 ounces of premium plus oil for Optimax engines per 10 gallons to lubricants the fuel system and injectors.

dirtman
11-29-2017, 06:01 PM
I do Larry. I was more asking about adding 8.5 ounces of premium plus oil for Optimax engines per 10 gallons to lubricants the fuel system and injectors.
Yeah....I'm not sure on the adding of the Premium Plus. Have never done that.

Snowblind
11-29-2017, 08:24 PM
I add nothing. Do use Mercury Premium Plus two stroke oil. Of course mine isn't nowhere near new like y'all is. Gets ran like a scolded dog though. No issues with the top end.....yet. Hope me sayin this doesn't jinx me.
Side note: Be careful with using the agm batteries with some model Mercs. I know the older EFIs, Optimax and a few others don't like the agms. Mercury advises not to use them.

31Airborne
11-30-2017, 07:30 AM
+1 on quickcleen. don't keep gas in my sled long enuff to warrant the others.

just1more
12-14-2017, 11:02 AM
Adding a little oil to the gas helps keep the the gas injectors internally lubricated. Gas residue builds up over time and could possibly cause the injector to fail. This is true weather its used a lot or sits. It cant hurt, thats for sure.

Squire
12-14-2017, 02:12 PM
I add nothing. Do use Mercury Premium Plus two stroke oil. Of course mine isn't nowhere near new like y'all is. Gets ran like a scolded dog though. No issues with the top end.....yet. Hope me sayin this doesn't jinx me.
Side note: Be careful with using the agm batteries with some model Mercs. I know the older EFIs, Optimax and a few others don't like the agms. Mercury advises not to use them.

modern 31series AGM's are approved. Here are some good reads:

http://www.bbcboards.net/showthread.php?t=655126

http://www.bbcboards.net/showthread.php?t=20671

Snowblind
12-14-2017, 06:04 PM
modern 31series AGM's are approved. Here are some good reads:

http://www.bbcboards.net/showthread.php?t=655126

http://www.bbcboards.net/showthread.php?t=20671

Contact Mercury and CDI electronics and they'll tell you they dont recommend the newer agms for certain Mercury outboards. I've burnt up two rectifiers and a fuel pump. The Sears PM was the cause for the fuel pump so I went out and got the Duracell 31 agm. Yep....caused the rectifier to burn up. Mercury and CDI both recommend if I wanted to run a 31 series, get the Deka 31 Dc31 with 1000 Mcas.
Just passing along with what first mercury told me then calling CDI to verify.
Bob Toller even said the same thing when I mentioned to him with the two previous had told me.

Squire
12-14-2017, 06:44 PM
Contact Mercury and CDI electronics and they'll tell you they dont recommend the newer agms for certain Mercury outboards. I've burnt up two rectifiers and a fuel pump. The Sears PM was the cause for the fuel pump so I went out and got the Duracell 31 agm. Yep....caused the rectifier to burn up. Mercury and CDI both recommend if I wanted to run a 31 series, get the Deka 31 Dc31 with 1000 Mcas.
Just passing along with what first mercury told me then calling CDI to verify.
Bob Toller even said the same thing when I mentioned to him with the two previous had told me.

second post start with: This data was provided by Mercury Marine's R&D Department. Don Weed at BBC has 40 years expertise...I'll trust him thank you.

there are dual cranking/deep series batteries available now. I seriously doubt a 31 series deepcycle battery
was responsible for your "burnt up "old" chit"....just sayin buddy...

BTW, I know Bob Toler WELL....He HATES dealing with electrical chit.....just ask him :)